$re = '/\b\p{L}(?:\h+\p{L}){2,}\b(?![\s\p{P}]*$)/';
$str = 'Lorem i p s u m dolor sit a m e t, consectetur adipiscing e l i.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);