package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Select Sizes(\S+)\s*(\S+)\s*(\S+)\s*(\S+)`)
var str = `Select SizesS M L XL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}