$re = '/(?<=(\w\w:)|(\w:))[ \t]+(.*\n?)\1?\2?/';
$str = 'a: 1, 2, 3
a: a, b, v
b: 5, 6, 7
b: 10, 1543, 1345
b: e, fe, sdf
cd: asdf, asdfas dfasdfa,asdfasdfa,afdsfa sdf
e1: asdfas, dafasd, adsf, asdfasd
e1: 1, 3, 2
e1: 9, 8, 7, 6
d: 9, 8, 7, 6';
$subst = "\t\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;