$re = '/#[^ #]+(?:(?: +[^ #]+)*#)?/';
$str = 'rain in #SPAIN stays #The t,-est# rain in #SPAIN stays mainly in the #plain';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);