# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[1-9]+\.+[0-9]+(e\+|E\+)[2-9]+[0-9]+"
test_str = ("1.2917967061810938e+20\n"
"1.2917967061810938e-20\n\n"
"1.2917967061810938E+20\n"
"1.2917967061810938E-20\n\n"
"1.2917967061810938e+20\n"
"6.162625864261435e+18\n"
"1.232525172852287e+19\n\n"
"10000\n\n"
".00001\n"
"1211.\n\n"
"0.12791\n"
"1.20932\n"
"10032.02\n\n"
"1.000e-20\n"
"1.00e+20")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.