$re = '/^\w+$\n/m';
$str = 'zer00ne
is a bad ass
all
of
these
should
match
this will not match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);