re = /^{{(?:(?!{{|\/}}).)*\/}}$/m
str = '{{ name xxxxxxCONTENTxxxxx /}}
{{ name }} xxxxxxxCONTENTxxxxxxx {{ name /}}
{{ name xxxxxxCONTENTxxx {comand} xxxxCONTENTxxx /}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end