import re
regex = re.compile(r".*([Ss][0-9].[eE][0-9].)+.")
test_str = "The.Big.Bang.Theory.S08E01.HDTV.x264-LOL.[VTV].mp4"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")