re = /\[[^\]]*\](?!\[)/
str = 'foo[bar][][foo]
x[]
asdf[x]
fdsa[][hello]; thing[][][]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end