package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.*?(\bbad\b)[^$]*)$`)
var str = `bad`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}