$re = '/\bNew(\S.+?):/';
$str = 'holla holla testing is for NewFinancial History:\\"xyz\\" dsd NewFinancial History:\\"abc\\" New Investment History:\\"abc\\" dsds ";
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);