package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*example\.com\/([a-zA-Z0-9-]+)`)
var str = `https://www.example.com/testcategory`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}