$re = '/(?im)^#[0-9]{5,7},(.*)/';
$str = '#12345, Some description1
#123456, Some description2
#1234567, Some description3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);