$re = '/\$color_base1(;|\b)/';
$str = '$color_base1
$color_base1;
$color_base2
$color_base11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);