$re = '/\s*((\w+)=([\'\"])(.*?)\3)\1*/i';
$str = '<?xml version="1.0" encoding="UTF-8"?>
<root-topic docid="10001048" docstatus="Draft"
id="LegalConsiderations-17D8778D"><title>Legal Considerations</title>
<shortdesc>Legal Considerations</shortdesc>
<p product_type="accessories;chassis;enclosure;power supply">Video
and audio surveillance can be regulated by laws that vary from country
to country. Check the laws in your local region before using this
product for surveillance purposes.</p>
<p product_type="audio device">Audio surveillance can be regulated
by laws that vary from country to country. Check the laws in your
local region before using this product for surveillance purposes.</p>
<p network_video_products="audio"
product_type="network camera;video encoder;thermal camera;AVHS;ACM;ACS;application;O3C"
>Video and audio surveillance can be regulated by laws that vary from
country to country. Check the laws in your local region before using
this product for surveillance purposes.</p>
<p network_video_products="no audio"
product_type="network camera;video encoder;thermal camera">Video surveillance
can be regulated by laws that vary from country to country. Check
the laws in your local region before using this product for surveillance
purposes.</p>
<p network_video_products="audio"
product_type="network camera;video encoder;thermal camera">This product
includes one (1) H.264 decoder license and one (1) AAC decoder license.
To purchase further licenses, contact your reseller.</p>
<p network_video_products="no audio"
product_type="network camera;video encoder;thermal camera">This product
includes one (1) H.264 decoder license. To purchase further licenses,
contact your reseller.</p>
<p product_type="thermal camera">This product is subject to export
control regulations. You should always consult and comply with the
regulations of the appropriate local export control authorities.</p>
</root-topic>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);