package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:/(/[^/]+)+\.(?:jpg|gif|png)`)
var str = `http://www.medivision360.com/pharma/pages/articleImg/thumbnail/thumb3756d839adc5da3.jpg`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}