package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\.\d+\.\d+:\s?(\w+ \w+)`)
var str = `20:30-22:30 13.05.2015: Manfred treffen Repeat: FREQ=WEEKLY;BYDAY=WE;WKST=MO
09.05. - 12.05.2015: Britt Besuch`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}