package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[:?]\s+\[[^, \]]*[, ]?[^\]]*\]`)
var str = ` : [J, BASIC]
? [CINTERMEDIATE]
: [D,MEDIUM]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}