using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@[^\s@\/\+]+";
string input = @"@usera.sdf aaa bbb @userb ccc ddd eee @userc fff ggg @sdfsd+2
@@sdl@kj //@//sdflkj/ /@sdlkfj/ @ @a";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}