re = /(how|you|doing)/i
str = '<li><span>well</span> how you <span>doing</span></li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end