$re = '/^(?!.*(\d)\1{5})[A-Z0-9]{9,15}$/m';
$str = '00THZY7564TTX
X0000000TEVBV
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);