# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\>(.*?)\<"
test_str = ("<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
"<retorno><estoques><estoque><id>15872782438</id><codigo>teste-branco</codigo><nome>teste cor:branco</nome><estoqueatual>15</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>15</saldo><saldovirtual>15</saldovirtual></deposito></depositos></estoque><estoque><id>15872782439</id><codigo>teste-azul</codigo><nome>teste cor:azul</nome><estoqueatual>129</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>129</saldo><saldovirtual>129</saldovirtual></deposito></depositos></estoque><estoque><id>15872782441</id><codigo>teste-preto</codigo><nome>teste cor:preto</nome><estoqueatual>35</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>35</saldo><saldovirtual>35</saldovirtual></deposito></depositos></estoque><estoque><id>15872782434</id><codigo>teste</codigo><nome>teste</nome><estoqueatual>0</estoqueatual><depositos><deposito><desconsiderar>N</desconsiderar><id>14886649591</id><nome>Geral</nome><saldo>0</saldo><saldovirtual>0</saldovirtual></deposito></depositos></estoque></estoques></retorno>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.