package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Z]{2}[-]?[0-9]{8}$`)
var str = `UY98005826`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}