$re = '/^[+0][.\- ]?[0-9][.\- ]?[0-9][.\- ]?[0-9]+$/';
$str = '+91-9041742722';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);