$re = '/(([a-zA-Z0-9]{1,63}|[a-zA-Z0-9][a-zA-Z0-9-]{0,61}[a-zA-Z0-9])\.){0,3}[a-zA-Z]{2,63}\b(?!\.)/m';
$str = 'site.com 1.site.com 2.1.site.com 3.2.1.site.com 4.3.2.1.site.com, 5.4.3.2.1.site.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);