const regex = /(?:===Verb===|===Noun===|===Adjective===|===Adverb===)(.*?)====Translations====/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:===Verb===|===Noun===|===Adjective===|===Adverb===)(.*?)====Translations====', 'g')
const str = `<root><h level="2" i="1">==English==</h> <template lineStart="1"><title>wikipedia</title><part><name>dab</name>=<value>overflow</value></part><part><name>lang</name>=<value>en</value></part></template> <h level="3" i="2">===Etymology===</h> From <template><title>prefix</title><part><name index="1"/><value>over</value></part><part><name index="2"/><value>flow</value></part><part><name>lang</name>=<value>en</value></part></template>. Literally corresponds to <template><title>term</title><part><name index="1"/><value>superfluous</value></part><part><name>lang</name>=<value>en</value></part></template>, which is from Latin, rather than Germanic. <h level="3" i="3">===Pronunciation===</h> * <template><title>a</title><part><name index="1"/><value>RP</value></part></template> ** <template><title>sense</title><part><name index="1"/><value>noun</value></part></template> <template><title>enPR</title><part><name index="1"/><value>ōʹvə-flō'</value></part></template>, <template><title>IPA</title><part><name index="1"/><value>/ˈəʊvəˌfləʊ/</value></part><part><name>lang</name>=<value>en</value></part></template> ** <template><title>sense</title><part><name index="1"/><value>verb</value></part></template> <template><title>enPR</title><part><name index="1"/><value>ō'və-flōʹ</value></part></template>, <template><title>IPA</title><part><name index="1"/><value>/ˌəʊvəˈfləʊ/</value></part><part><name>lang</name>=<value>en</value></part></template> * <template><title>a</title><part><name index="1"/><value>GenAm</value></part></template> ** <template><title>sense</title><part><name index="1"/><value>noun</value></part></template> <template><title>enPR</title><part><name index="1"/><value>ōʹvər-flō'</value></part></template>, <template><title>IPA</title><part><name index="1"/><value>/ˈoʊvɚˌfloʊ/</value></part><part><name>lang</name>=<value>en</value></part></template> ** <template><title>sense</title><part><name index="1"/><value>verb</value></part></template> <template><title>enPR</title><part><name index="1"/><value>ō'vər-flōʹ</value></part></template>, <template><title>IPA</title><part><name index="1"/><value>/ˌoʊvɚˈfloʊ/</value></part><part><name>lang</name>=<value>en</value></part></template> * <template><title>rhymes</title><part><name index="1"/><value>əʊ</value></part><part><name>lang</name>=<value>en</value></part></template> <h level="3" i="4">===Noun===</h> <template lineStart="1"><title>en-noun</title></template> # The [[spillage]] resultant from overflow; [[excess]]. # [[outlet|Outlet]] for escape of excess material. # <template><title>context</title><part><name index="1"/><value>computing</value></part><part><name>lang</name>=<value>en</value></part></template> The situation where a value exceeds the available [[numeric]] [[range]]. <h level="4" i="5">====Translations====</h> <template lineStart="1"><title>trans-top</title><part><name index="1"/><value>spillage</value>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}