const regex = /\"ou\"\:\"(https?:\/\/.*\.(?:png|jpg|jpeg|gif))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"ou\\"\\:\\"(https?:\\\/\\\/.*\\.(?:png|jpg|jpeg|gif))', 'gi')
const str = `{"cb":21,"cl":3,"cr":3,"ct":21,"id":"dW5GZvKh_3M_2M:","isu":"www8.hp.com","itg":false,"ity":"png","oh":356,"ou":"http://product-images.www8-hp.com/digmedialib/prodimg/lowres/c03235671.png","ow":474}
{"cb":21,"ct":21,"id":"9br0fx79WphEoM:","isu":"centrecom.com.au","itg":false,"ity":"jpeg","oh":400,"ou":"https://centrecomstatic.s3.amazonaws.com/images/upload/0015329_0.jpeg","ow":400}
{"cb":21,"cl":3,"cr":3,"ct":21,"id":"JhRyJSH9KgtexM:","isu":"www8.hp.com","itg":false,"ity":"png","oh":356,"ou":"http://product-images.www8-hp.com/digmedialib/prodimg/lowres/c03235691.png","ow":474}
{"cb":21,"cl":3,"cr":3,"ct":21,"id":"r0jI0V0ECpUxCM:","isu":"www8.hp.com","itg":false,"ity":"png","oh":356,"ou":"http://product-images.www8-hp.com/digmedialib/prodimg/lowres/c03235770.png","ow":474}
{"ct":3,"id":"ySkYQ0zkDOWQaM:","isu":"amazon.com","itg":false,"ity":"jpg","oh":524,"ou":"https://images-na.ssl-images-amazon.com/images/I/715CMBwfmtL._SL1500_.jpg","ow":1500}
{"cl":3,"cr":3,"id":"4XMWsfu3vQSwcM:","isu":"geb.ebay.in","itg":false,"ity":"jpg","oh":354,"ou":"http://i.ebayimg.com/00/s/NjQxWDkwNQ\\u003d\\u003d/z/vD0AAOSwyQtVm-3Z/\$_12.JPG?set_id\\u003d880000500F","ow":500}
{"cb":3,"cl":3,"ct":3,"id":"nl8KfxeJ1X1X1M:","isu":"argep.hu","itg":false,"ity":"jpg","oh":239,"ou":"http://www.usanotebook.hu/termekek/HP-Compaq-NB-USB-3.0-port-replikator-3005pr-32216A.jpg","ow":550}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}