$re = '/(?<=\()\d+(?=\))/';
$str = 'gene1 (100)
gene2 (50)
gene3 (120)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);