$re = '/(?<Message>.*?)[\.](?:[\s]id:(?<id>.*)[\.])? Code:(?<Code>.*)[\.]/im';
$str = 'Failed to send sms. code:5063.
Failed to send sms. id:23. code:5063.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;