// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Max [^:]+): ([\d.]+)").unwrap();
let string = "mps): 22.624001\\r\\nMax Phase Current Gain Error (Percent): 0.500000\\r\\nMax Phase Current Offset Error (Amps): 0.113120\\r\\nFan Control Timer (nS): 60000002048.000008\\r\\nPWM Dead Time (uS): 0.000004\\r\\n\\r\\n--------------------------AXIS_INSTANCE_3--------------------------\\r\\n\\r\\nPiccolo ServoIO Stats :\\r\\n\\tTotal Missed Read Phase : 0\\r\\n\\tTotal Missed Write Phase : 0\\r\\n\\tTotal Read CRC Error : 0\\r\\n\\tTotal Write CRC Error : 0\\r\\n\\tTotal Invalid Seq. ID : 0\\r\\n\\tTotal (General) Sequence Errors : 1\\r\\n\\r\\nOmap to Piccolo Read Packet :\\r\\nCommand/Fault Word : 0x0\\r\\nSequenceAndIncipSize : 0xc0\\r\\n\\r\\nOmap to Piccolo Read Packet :\\r\\nCommand/Fault Word : 0x0\\r\\nSequenceAndIncipSize : 0xc0\\r\\n\\r\\nPiccolo to Omap Read Packet :\\r\\nUPhase Current : 32779\\r\\nWPhase Current : 32776\\r\\nVbus : 0\\r\\n\\r\\nOmap to Piccolo Write Packet :\\r\\nUPhase Mod Idx : 0\\r\\nVPhase Mod Idx : 0\\r\\nWPhase Mod Idx : 0\\r\\n\\r\\nPiccolo to Omap Write Packet :\\r\\nStatus/Fault Word: 0x0\\r\\nSequenceAndIncipSize: 0x70\\r\\n\\r\\n\\r\\nPiccolo to Omap Low-Speed Data :\\r\\nPiccolo ADC Temp : 0.000000 degC\\r\\nPiccolo Igbt Temp : 23.618481 degC\\r\\n\\r\\nPower Interface Scaling:\\r\\nPhase Current Feedback Offset Counts: 32767.000000\\r\\nPhase Current Feedback Gain Scaling: -0.002142\\r\\nDC Bus Voltage Feedback Offset Counts: 0.000000\\r\\nDC Bus Voltage Feedback Gain Scaling: 0.013757\\r\\nMax Phase Current (Amps): 609.198303\\r\\nPhase Current Gain Error Measurement Point (Amps): 22.624001\\r\\nMax Phase Current Gain Error (Percent): 0.500000\\r\\nMax Phase Current Offset Error (Amps): 0.113120\\r\\nFan Cont
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}