re = /<script.*?>.*?<\/script>/im
str = '<\'<script></script>script type="text/javascript">al<script></script>ert("test");<\'<script></script>/script> '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end