import Foundation
let pattern = #"(B\d{2}\w{7})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
User account
Research
Bestseller
Watchlist
Monitoring
User List
Dashboard
Log out
Feedback
Add product(s)
Filters
Marketplace
Category
Title contains
Title contains
Tag equals
Tag equals
Brand equals
Brand equals
Seller equals
Seller equals
Buybox
Buybox
Amazon
FBA
FBM
Per page
Compare
Total products: 20
Previous 1 Next
Fav. Image MP Title
ASIN
Brand Price Sales rank
Category Buybox # Sellers # Reviews
Rating LQI Options
Sternenlichter Sternenhimmel 500 Leuchtpunkte
B019HAY3C4
Sternenlichter
€ 12.99
128075
Küche & Haushalt
FBA
FRIES Digital
1
49
4.1 90
Bentgo - Bento Box / Lunchbox inkl. Besteck (Lila)
B00B78W282
Bentgo
€ 17.90
10093
Küche & Haushalt
FBA
use-again
3
99
4.3 75
Bentgo - Bento Box / Lunchbox inkl. Besteck (Grün)
B00B78WO3U
Bentgo
€ 17.90
11190
Küche & Haushalt
FBA
use-again
1
99
4.3 75
Bentgo - Bento Box / Lunchbox inkl. Besteck (Blau)
B00B78T8U2
Bentgo
€ 17.90
10560
Küche & Haushalt
FBA
use-again
2
99
4.3 75
Bentgo - Bento Box / Lunchbox inkl. Besteck (Grau)
B00B78UBO4
Bentgo
€ 17.90
2658
Küche & Haushalt
FBA
use-again
2
99
4.3 75
Emsa 516943 3-teiliges Frischhaltedosenset, 1 Liter, Transparent/Blau, Clip & Close
B004QGXKRO
Emsa
€ 11.79
433
Küche & Haushalt
Amazon
40
297
4.6 90
Meal Prep Haven Lebensmittelbehälter mit 2 Fächern und Deckeln für die Portionskontrolle, ...
B011SUKOHE
Meal Prep Haven
box
463636
Küche & Haushalt
1
25
Mikrowelle und spülmaschinenfest stapelbar Mahlzeit Prep Kunststoff Lebensmittel Behälter ...
B0195971NU
Superior
box
€ 16.49
15941
Küche & Haushalt
FBA
K Master
1
40
3.9 65
Mikrowelle und spülmaschinenfest stapelbar Mahlzeit Prep Kunststoff Lebensmittel Behälter ...
B01BCNFT3Q
Superior
box
€ 16.89
11542
Küche & Haushalt
FBA
K Master
1
40
3.9 65
Mikrowelle und spülmaschinenfest stapelbar Mahlzeit Prep Kunststoff Lebensmittel Behälter ...
B017KNFDOM
Superior
box
€ 16.89
3630
Küche & Haushalt
FBA
K Master
2
40
3.9 55
Meal Prep Haven Lebensmittelbehälter mit 3 Fächern und Deckeln für die Portionskontrolle, ...
B011SY4P9I
Meal Prep Haven
box
46144
Küche & Haushalt
1
4
3.3 40
XL Silikon Backmatte von Cookin´Active, BPA frei, Platinum Silikon, Lebensmittelecht, Anti ...
B01AR1L0FU
Cookin'Active
€ 17.99
3234
Küche & Haushalt
FBA
Flatland Trading
1
35
5 90
WENKO 4374120100 Wäschesortierer Air - 6 breite Fächer, 100 % Polypropylen, 30 x 120 x 30 ...
B0034KYP1I
Wenko
hängeregal
€ 9.99
2669
Küche & Haushalt
Amazon
5
57
4.2 65
WENKO 64004100 Multi-Organizer Butterfly - 10 Fächer, 100% Polypropylen, 15 x 127 x 30 cm, ...
B00URLQRMW
Wenko
hängeregal
€ 11.99
451701
Küche & Haushalt
Amazon
4
45
Metaltex 751016 Hängeregal, 10 Fächer, 20 x 29 x 120 cm
B0098UXD3O
Metaltex
hängeregal
€ 14.07
357099
Küche & Haushalt
Amazon
1
20
Chintz, Vintage-Stil gemustert, 10 Taschen für Schuh-Aufbewahrung
B00KD875RU
Lloyd Pascal
hängeregal
€ 9.49
1540117
Küche & Haushalt
FBA
ramsdensdirect
2
20
WENKO 4372030100 Multiorganizer Comfort - 10 Fächer, Kunststoff - PEVA, 15 x 122 x 30 cm, ...
B001AI590W
Wenko
hängeregal
€ 9.99
34405
Küche & Haushalt
Amazon
3
11
3.9 20
Delete selected products
Previous 1 Next
Copyright © 2016 AMALYTIX.COM
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)