#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[ |]*(\w+)\s*(>?=|<)\s*([^:\n]+)(?:\s*:\s*([^\(]+))?(\(.*)?$"
Local $sString = "| | | | featureB >= 16104.33 : 18873.52 (1/0)" & @CRLF & _
"| featureA >= 17980.32" & @CRLF & _
"featureC = ABC BLAH BLAH blA'H $blah 4/ blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")