#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\()?(\+36|0036|06)?(\))?(-| )?(1|20|2[2-9]|3[0-7]|40|42|4[4-9]|5[2-7]|59|60|62|63|66|68|69|70|7[2-9]|80|8[2-5]|8[7-9]]|90|9[2-9])([\\\/ ])?(\d{6,7}|\d{3}(-| )\d{3,4}|\d{3,4}(-| )\d{3})"
Local $sString = "205032935" & @CRLF & _
"305032935" & @CRLF & _
"705032935" & @CRLF & _
"06303335554" & @CRLF & _
"+36205032935" & @CRLF & _
"0036205032935" & @CRLF & _
"" & @CRLF & _
"(06)-30\3333333" & @CRLF & _
"(06)-30\3333-333" & @CRLF & _
"(06)-303333333" & @CRLF & _
"(+36)303333333" & @CRLF & _
"(+36)-30\333 3333" & @CRLF & _
"(+36)-30/3333333" & @CRLF & _
"(0036)-30\333-3333" & @CRLF & _
"(0036)-30\3333 333" & @CRLF & _
"(0036) 303333333" & @CRLF & _
"" & @CRLF & _
"0036 74 555 556" & @CRLF & _
"+3674 555556" & @CRLF & _
"0674555 556" & @CRLF & _
"(06)74555556" & @CRLF & _
"(0036)-74/555-556" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")