$re = '/^(css|js|img)\/((?!private_).*)$/';
$str = 'img/private_fulano.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);