package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`bulkmail|offers|cheapbenefits|earnmoney|foryou`)
var str = `earnmoney `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}