package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^/.]*\.(\w+)[^/]*$`)
var str = `http://static.gazeta.ru/nm2012/fonts/light/pts_regular_caption.svg#PTSans-CaptionBold
http://2.cdn.echo.msk.ru/assets/../fonts/echo_font-v5.eot#iefix`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}