# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Placemark((.|\n)*)\/Placemark"
test_str = ("<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
	"<Document>\n"
	"	<name>culverts.XML</name>\n"
	"	<StyleMap id=\"m_ylw-pushpin29\">\n"
	"		<Pair>\n"
	"			<key>normal</key>\n"
	"			<styleUrl>#s_ylw-pushpin00</styleUrl>\n"
	"		</Pair>\n"
	"		<Pair>\n"
	"			<key>highlight</key>\n"
	"			<styleUrl>#s_ylw-pushpin_hl25</styleUrl>\n"
	"		</Pair>\n"
	"	</StyleMap>\n"
	"<Folder>\n"
	"		<name>culverts.XML</name>\n"
	"		<open>1</open>\n"
	"		<description>Culvert</description>\n"
	"		<Placemark>\n"
	"			<name>NODE36</name>\n"
	"			<description><![CDATA[<br><br><br>\n"
	"    <table border=\"1\" padding=\"0\">\n"
	"    <tr><td>Objectid</td><td>1</td></tr>\n"
	"    <tr><td>On_route</td><td>Midway Turnpike</td></tr>\n"
	"    <tr><td>Road_numbe</td><td>54</td></tr>\n"
	"    <tr><td>Recommenda</td><td>Continue to monitor.</td></tr>]]></description>\n"
	"			<styleUrl>#m_ylw-pushpin29</styleUrl>\n"
	"			<Point>\n"
	"				<extrude>1</extrude>\n"
	"				<altitudeMode>relativeToGround</altitudeMode>\n"
	"				<coordinates>-84.249045,35.997986,0</coordinates>\n"
	"			</Point>\n"
	"		</Placemark>\n"
	"		<Placemark>\n"
	"			<name>NODE44</name>\n"
	"			<description><![CDATA[<br><br><br>\n"
	"    <table border=\"1\" padding=\"0\">\n"
	"    <tr><td>Objectid</td><td>2</td></tr>\n"
	"    <tr><td>On_route</td><td>Midway Turnpike</td></tr>\n"
	"    <tr><td>Road_numbe</td><td>54</td></tr>\n"
	"    <tr><td>Recommenda</td><td>Not Available.</td></tr>]]></description>\n"
	"			<styleUrl>#m_ylw-pushpin29</styleUrl>\n"
	"			<Point>\n"
	"				<extrude>1</extrude>\n"
	"				<altitudeMode>relativeToGround</altitudeMode>\n"
	"				<coordinates>-84.24906300000001,35.998057,0</coordinates>\n"
	"			</Point>\n"
	"		</Placemark>\n"
	"	</Folder>\n"
	"</Document>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
    print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.