import re
regex = re.compile(r"^\+[1-9][\d]{8,14}(;ext=[\d]{3,6})?$", flags=re.MULTILINE)
test_str = ("+14160001234\n\n"
"+18001234567\n\n"
"+442012345678\n\n"
"+14160007890;ext=12345\n"
"# Max Digits is 15\n"
"+123456789012345\n"
"+123456789012345;ext=123456\n"
"+1234567890123456\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")