package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<prefix1>\d{0,2})(?:(?<threes1>\d{3})*)\/(?<prefix2>\d{0,2})(?<threes2>\d{3})*\s`)
var str = `0/1 -> [,,0,1]
1234/3 -> [1,234,,3]
12345/1234 -> [12,345,1,234]
123456/789123 -> [123,456,789,123]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}