re = /((?:description|speed|type|peers)(?=\s+set)|classify)/
str = 'description set
description classify'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end