package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|\s+)\+(\w+)`)
var str = `+aaa +bbb ++ccc ddd eee+ fff++ +ggg hhh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}