package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*\/)(.*)$`)
var str = `vimeo.com/99612902
www.vimeo.com/99612902
http://vimeo.com/99612902
http://www.vimeo.com/99612902`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}