$re = '/[A-Za-z0-9]*[\/arcgis\/rest\/services\/](.*)[\/MapServer]+/m';
$str = 'vimeo.com/99612902
www.vimeo.com/99612902
http://vimeo.com/99612902
http://www.vimeo.com/99612902
http://sampleserver6.arcgisonline.com/arcgis/rest/services';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);