$re = '/\A(?=\D*\d)(?=[^A-Z]*[A-Z][^A-Z]*\z)[A-Za-z\d]{4}\z/';
$str = 'e3Wd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);