#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<brackets>[\[\]\(\)]){0}" & @CRLF & _
"?(?<tab><HT>){0}" & @CRLF & _
"?(?&tab)(?&brackets)?(?<longitude>[0-9\.]{1,})(?&brackets)?" & @CRLF & _
"?(?&tab)(?&brackets)?(?<latitude>[0-9\.]{1,})?(?&brackets)?" & @CRLF & _
"?(?&tab)(?&brackets)?(?<speed>[0-9\.]{1,6})?(?&brackets)?" & @CRLF & _
"?(?&tab)(?&brackets)?(?<azimut>[0-9\.]{1,6})?(?&brackets)?" & @CRLF & _
"?(?&tab)(?&brackets)?(?<IMEI>[0-9]{15})?(?&brackets)?" & @CRLF & _
"?(?&tab)(?&brackets)?(?<IMSI>[0-9]{15})?(?&brackets)?"
Local $sString = "<HT>(21.123456)<HT>(51.123456)<HT>(20.31)<HT>(120.48)<HT>(260032995142244)<HT>(355233057612051)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")