re = /(\s|[!-\/]|[:-@]|[\[-`]|[\{-~])*\s(\s|[!-\/]|[:-@]|[\[-`]|[\{-~])*/
str = 'She said - \'That\'ll be `all, Two-Fry.\' руский and ไทอ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end