#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<="name": ")(.+)(",\n\s+"war_memorials": ")(.*?\1,)(.*?)(,.*)(?=",)"
Local $sString = ""properties": {" & @CRLF & _
" "cartodb_id": 2," & @CRLF & _
" "sortcode": 3," & @CRLF & _
" "pop2011": 612431," & @CRLF & _
" "pop2002": 652625," & @CRLF & _
" "pop1992": 681206," & @CRLF & _
" "pop1977": 631918," & @CRLF & _
" "pop1966": 529833," & @CRLF & _
" "pop1956": 483741," & @CRLF & _
" "pop1948": 448964," & @CRLF & _
" "regionid": 3," & @CRLF & _
" "countycode": 38," & @CRLF & _
" "countyid": 3," & @CRLF & _
" "region": "Sud"," & @CRLF & _
" "mnemonic": "AG"," & @CRLF & _
" "name": "Argeș"," & @CRLF & _
" "war_memorials": "București,132,Alba,145,Brașov,151,Covasna,100,Harghita,188,Mureș,363,Sibiu,165,Bacău,188,Botoșani,149,Iași,246,Neamț,235,Suceava,219,Vaslui,212,Bihor,199,Bistrița-Năsăud,120,Cluj,186,Maramureș,,Satu Mare,119,Sălaj,79,Brăila,47,Buzău,188,Constanța,89,Galați,,Tulcea,87,Vrancea,76,Argeș,252,Călărași,115,Dâmbovița,191,Giurgiu,180,Ialomița,113,Prahova,162,Teleorman,202,Dolj,212,Gorj,154,Mehedinți,110,Olt,163,Vâlcea,185,Arad,233,Caraș-Severin,176,Hunedoara,118,Timiș,321"," & @CRLF & _
" "version": "2016-03-10T00:00:00Z"," & @CRLF & _
" "comune": 95," & @CRLF & _
" "orase": "4"" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
""
Local $sSubst = "\1\2\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)