$re = '/^\+467\d{0,8}$/m';
$str = '+46708112233
0046708112233
+46708-112233
460708112233
0708-112233';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);