re = /limit(.+)/m
str = '✔ nnn : am
-limitaaaa
ça UNICODE HERE
sdasdsadaw
✔ UNICODE HERE
limitaaaa,.@#!~`%$&*()[]{}|\\+=-_?/\'":;.><,
777723xx sss fff s :,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end